Date archives "diciembre 2013"

Propósitos para 2014

Casi sin tiempo no podía dejar pasar el 2013 sin preparar una lista, esta vez más acorde a la realidad, de lo que espero en este 2014.

Cuando llega final de año muchos tenemos la tendencia a hacer un resumen y pensar en aquello con lo que nos quedamos y aquello que nos gustaría cambiar.

Mi 2014 va a tener tres grandes objetivos.

1. Decisión. Mi talón de Aquiles eterno. Mi incapacidad para tomar decisiones muchas veces ha significado tomar la más incorrecta de todas las posibles: ninguna. Quiero y pienso esforzarme mucho por ser capaz de tomar las decisiones adecuadas evaluando todo aquello que en el momento de tomarlas tenga a mi alcance. Aceptar esas decisiones como las correctas en ese momento y no mirar más hacia atrás.

2. Reflexión. Una de las grandes cosas que siempre ha estado en mi lista de propósitos y que jamás me he aventurado a darle forma ha sido la de la meditación. He tenido tímidos intentos pero nunca me lo he tomado en serio. Este 2014 va a ser el año de meditar, comprender, aprender y aceptar.

3. Cuerpo. Este último año he dado un salto cuantitativo en cuanto a lo que se refiere al deporte en mi vida diaria. Ahora falta completarlo. Manteniendo y mejorando mi día a día y, además, complementándolo con una alimentación más sana y adecuada.

Nada más que tres. Luego ya detrás están los de siempre: dejarme tiempo para disfrutar de mis pequeños placeres, conseguir un título de inglés, seguir mejorando mis conocimientos, seguir mejorando como persona y como profesional, etc.

Por cierto, intentaré ser razonable este año y marcarme como objetivo los 36 libros. 

 

Crítica: En Llamas (Los Juegos del Hambre 2)

Analizar una adaptación es siempre tarea complicada. Resulta complejo tratar de entender hasta que punto el director ha sido capaz de transmitir en la gran pantalla aquello que la imaginación de cada uno proyecta a medida que lees la novela.

La situación es aún más difícil si lo que se adapta es una historia que no ha terminado de convencerte.

img_enllamas1

Como ya dije en su día, la saga de Los Juegos del Hambre es una obra más bien justa. Digamos que pertenece al género comúnmente conocido como «del montón». Se hace amena de leer y quizá lo que la hace particularmente criticable es el hecho de que la idea con la que nace es interesante pero su desarrollo y, sobretodo, su desenlace, son nefastos.

Estas Navidades han traído dos segundas partes, la esperada continuación de «Esa-película-que-se-llama-el-Hobbit», un subproducto parido por Peter Jackson con la única sana intención de llenarse todavía más los bolsillos a costa de los seguidores menos seguidores, y esta «En Llamas», que continúa la historia de Katniss Everdeen tras los hechos acontecidos durante Los 74º Juegos del Hambre. 

En líneas generales y salvando algunos agujeros difícilmente comprensibles en el guión, la adaptación es correcta. Como era de esperar de un libro de 400 páginas escrito en presente y en primera persona. Cuando lo lees sabes que la autora le ha puesto las cosas muy fáciles al posible traslado cinematográfico.

img_enllamas2

Los protagonistas ya me convencieron en la primera edición y mantienen el tono durante esta secuela. Los nuevos personajes, especial mención a Phillip Seymour Hofmann, están a la altura de sus compañeros. La banda sonora, la fotografía y unos escasos pero competentes efectos especiales también contribuyen a dotar a la historia de los componentes necesarios para que resulte entretenida de ver.

Que está claro que hay bodrios peores en cartelera y que estando en estas fechas tan señaladas no es una mala excusa para juntar a la familia en una película que salga un poco del marco de las «3D movies» prefabricadas con las que últimamente nos rellenan los cines. Pero que nadie se lleve las manos a la cabeza si tras ver esta continuación sale con el mismo cuerpo con el que entró y con la sensación de que la curva que traza es descendente.

Porque lo es. La tercera parte es, sin ningún género de dudas, la peor con diferencia. 

Crítica: La Historia de tu vida – Ted Chiang

Quizá una de las herramienta más maravillosas que tiene el ser humano es la imaginación. La capacidad de, sólo con el poder de la mente, dibujar un sinfín de mundos lejanos, de sombras de lo desconocido, y entretejer historias imposibles.

Ted Chiang es un ejemplo fantástico de ello.

img_historia_2

La Historia de tu vida [Amazon España – Bibliópolis] no es una novela sino una colección de pequeños relatos. Delicados tesoros que son a su vez retales de imaginaciones, de creatividad en estado puro.

Ocho historias. Sin relación entre sí. Mostrándonos a través de la ventana de nuestra realidad actual un futuro inimaginable, una alternativa que no cabe en nuestra estructurada mente anclada al dogma de una vida con las normas ya escritas. ¿Por qué no romperlas? ¿Por qué no intentar ver más allá de lo que la razón decide en un determinado momento que es imposible?

Imagino a aquellos seres humanos que vivieron hace trescientos años. Un suspiro en la inmensidad del tiempo del universo. Y pese a eso sería para ellos inimaginable la visión de un ser humano siendo transportado por gigantes alados, disponiendo de todo el saber de la humanidad en la palma de su mano, en cualquier momento. ¿Qué nos pueden estar deparando los futuros que ya no alcanzaremos a ver?

img_historia_1

La primera de las historias es La Torre de Babilonia: ciencia ficción en retrospectiva. ¿Y si la Torre hubiera existido? ¿Y si el ser humano hubiese alcanzado el cielo? La segunda, Dividido entre cero, es un ejercicio de reflexión contra lo establecido ¿qué sucedería si los axiomas sobre los que sustentamos nuestra vida dejasen de ser ciertos? ¿cómo trastocaría nuestra fingida estabilidad al saber que los pilares sobre los que yace se desmoronan?

Y así todos y cada uno de los relatos conducen al lector a un proceso de reflexión, a lanzarse las preguntas adecuadas que ya no alteren su realidad sino que la pongan en entredicho. 

Personalmente he disfrutado mucho con «La historia de tu vida« y «Comprende«, dos historias que al terminarlas consiguieron que bordease por primera vez el abismo de lo incomprensible. Que fuese capaz de plantearme una realidad ajena a aquello que considero cierto de forma innata.

img_historia_3

Si te gusta la Ciencia Ficción esta es sin duda una obra que deberías leer al menos una vez en tu vida.

Muy recomendable.

Nota: 8.5/10

Repasando los propósitos de 2013

Resulta cuanto poco curioso, un año después, analizar los propósitos que dejaste escritos y ver hasta que punto has tenido éxito durante todo este tiempo.

Antes que nada, he de reconocer que cometí dos errores de bulto a la hora de definir mis propósitos para 2013.

Por un lado la falta de definición explícita del objetivo. Muchos, más allá de propósitos, se acercan más al concepto de “deseos” sin dejar claro en qué caso se puede considerar como completado el propósito y en qué caso no.

Por otro, el exceso de ellos. He aprendido que el que mucho abarca termina por no tener la energía suficiente para completarlo todo. Reconocer que disponemos de un depósito limitado de combustible vital me está costando bastante de entender, pero poco a poco lo voy asumiendo.

img_purpose

Pero no nos liemos, a la lista, que es a lo que habíamos venido.

1. Disfrutar de la vida. Es el primero porque es el más importante. Este 2012 ha tenido momentos geniales y momentos bastante complicados que me han llevado a la conclusión de que estamos en este mundo para disfrutar de cada uno de los momentos que nos brinda la vida rodeados de la gente que queremos.

El primero en la frente. Esto ni es propósito, ni objetivo, ni “na de na”. Esto es como decir: voy a ver el azul del cielo más azul. Podría llegar a decir que este año he aprendido a valorar más los momentos sin pensar demasiado en lo que esté por venir. Pero no siempre es la mejor opción.

2. Crecer cultural y profesionalmente. Uno de los leitmotivs de la vida es, sin lugar a dudas, la percepción de crecimiento personal. Y esto en gran medida se consigue mejorando tus capacidades y tus aspiraciones. Este año que empieza va a ser importante en esto y por ello quiero formarme incansablemente desde el día 1.

Otro propósito ambiguo. En este caso sí que puedo decir que en su mayor parte lo he llevado a cabo. He seguido formándome y creciendo a todos los niveles. El mejor ejemplo es, sin duda, mi cambio de trabajo hace unas pocas semanas que supone la culminación a un año de cambios y desafíos y el inicio de una nueva etapa ilusionante.

3. Mens sana in corpore sano. Quiero tener un equilibrio mental/físico que me lleve a cumplir el primer objetivo con garantías. Por eso quiero imponerme una disciplina deportiva mayor de la que ya tengo.

Ha sido complicado, pero en líneas generales he mantenido una constante deportiva durante todo el año. La mejor forma de sentirse bien con uno mismo en todos los ámbitos de la vida pasa por ese equilibrio del que hablaba en el propósito. Y realmente funciona. Un año después sigo esforzándome por subir un poco más alto o correr un poco más lejos cada día.

4. Leer 50 libros.

Para uno que defino claramente y suelto esta bravuconada. No obstante, a pesar de todo, 25 han sido los libros que he leído este año, superando los 20 del año pasado, lo cual no está nada mal.

5. Tocar 12 piezas de piano.

Esto ya si que es insostenible. Han sido 2, que algo es algo, pero el piano sigue siendo mi talón de Aquiles personal: es el duro pero realista ejemplo del quiero y no puedo.

6. Visitar un nuevo país.

Por desgracia este año no he tenido la oportunidad de salir de España y queda en el Debe de mi cuenta personal el cumplirlo.

7. Certificarme. Conseguir el pleno de CCNAs y quizá el CCDP, amén de otras certificaciones: inglés, Juniper, VMWare, Microsoft…

Conseguí obtener los CCNA de Seguridad y de Voz lo cual ya es un gran paso que completó mi peregrinación por las certificaciones de Cisco, de momento.

8. Concentrarme para llevar el blog/redes sociales/proyectos personales al día.

Se puede decir que he mantenido cierta constancia en todos ellos, pero me sigue faltando la regularidad que me gustaría y, en muchos aspectos, la coherencia en la temática.

9. Concluir con éxito uno o varios proyectos profesionales.

Todavía ando detrás de la “idea” que me impulse a dar el salto de nuevo hacia el mundo emprendedor. Creo que todo el paso por el 49k y por Walá! trajo un desgaste del que todavía estoy recuperándome.

10. Ser capaz de hacerlo todo y sentirme bien con cada cosa que hago. En definitiva: ser feliz.

Y el último pero no por eso el peor, es un refrito del primero pero con el toque anuncio de compresas. Supongo que tenía la intención de llegar a 10 y tuve que terminar rellenando con lo que se me ocurrió.

Al final, lo importante es la segunda parte del propósito, la de sentirse bien con cada cosa que uno hace a pesar de que no se alcance lo que inicialmente se deseaba. Resumiendo, he de reconocer que pese a la indefinición de muchos de los objetivos, el balance de 2013 ha sido positivo y además deja la puerta abierta para que 2014 sea un año de crecimiento y de mejora continua.

Tras este breve análisis de los objetivos/propositos/deseos/y otros del 2013 ya estoy preparando la lista para 2014, en la que obviamente volveré a cometer el error de creerme capaz de llegar más lejos todavía.

Pero de eso se trata, de apuntar alto, tan alto como a la luna si hace falta, si uno falla, termina yendo hacia las estrellas.

LAB: Configuración Básica de OSPF

Dado el siguiente escenario:

LAB_1

Tenemos dos routers asociados a dos redes LAN independientes que no tienen conectividad entre sí. El objetivo de este laboratorio será definir un área OSPF común en el que los routers intercambien las rutas a su redes internas a través de la misma.

Para ello configuramos en primer lugar el router de Valencia:

Empezaremos definiendo las interfaces. Al tratarse de un router de la serie 1700 sólo disponemos de una interfaz FastEthernet que será la que emplearemos para conectarnos con el router del ISP. Para emular la subred de Valencia asignaremos la IP del rango 10.1.0.0/16 a una interfaz Loopback que hará las funciones de equipo dentro de la subred.

interface FastEthernet0
 description ENLACE CON MADRID
 ip address 10.0.0.1 255.255.255.252

interface Loopback0
 ip address 10.1.0.1 255.255.0.0
!

Realizaremos el mismo proceso en el router de Madrid:

interface FastEthernet0
 description ENLACE CON VALENCIA
 ip address 10.0.0.5 255.255.255.252

interface Loopback0
 ip address 10.1.0.1 255.255.0.0

Y por último el router del ISP dispondrá de dos enlaces FastEthernet dedicados a cada sede:

interface FastEthernet0/0
 description ISP TO VALENCIA
 ip address 10.0.0.2 255.255.255.252
!
interface FastEthernet1/0
 description ISP TO MADRID
 ip address 10.0.0.6 255.255.255.252
!

Una vez configurados los equipos podemos comprobar que desde la LAN de Valencia no se alcanza la LAN de Madrid.

VALENCIA#ping 10.2.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Si observamos la tabla de enrutamiento veremos cómo, como es obvio, el router de Valencia sólo puede alcanzar las redes a las que está conectado.

VALENCIA#sh ip route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/30 is directly connected, FastEthernet0
C       10.1.0.0/16 is directly connected, Loopback0

Para solucionar esta situación haremos uso de un protocolo de enrutamiento dinámico: OSPF.

Debemos definir un Área OSPF en la que los tres dispositivos intercambien rutas. Como el Router ISP no tiene rutas propias que intercambiar nos servirá exclusivamente de pasarela entre Valencia y Madrid.

Configuraremos de forma análoga OSPF tanto en Valencia como en Madrid.

VALENCIA
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.3 area 0
 network 10.1.0.0 0.0.255.255 area 0

MADRID
router ospf 1
 log-adjacency-changes
 network 10.0.0.4 0.0.0.3 area 0
 network 10.2.0.0 0.0.255.255 area 0

Por último configuraremos OSPF en el ISP y observaremos como se producen las adyacencias oportunas.

router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.3 area 0
 network 10.0.0.4 0.0.0.3 area 0

Una vez el proceso converge, las rutas de todos los dispositivos han sido compartidas y nos encontramos con que las tablas de enrutamiento de los 3 routers han sufrido una actualización gracias al proceso OSPF. Esto nos va a permitir tener interconectividad entre las redes LAN de Madrid y Valencia.

VALENCIA#ping 10.2.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/52/96 ms

ISP#sh ip route
Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.0.0.8/30 is directly connected, FastEthernet2/0
O       10.2.0.1/32 [110/2] via 10.0.0.5, 00:07:28, FastEthernet1/0
O       10.1.0.1/32 [110/2] via 10.0.0.1, 00:07:28, FastEthernet0/0
C       10.0.0.0/30 is directly connected, FastEthernet0/0
C       10.0.0.4/30 is directly connected, FastEthernet1/0

Podéis descargaros la topología para GNS3  con la configuración aplicada desde el siguiente enlace:

http://www.sergiomadrigal.com/labs/OSPF1.zip

Introducción a la QoS

Con el aumento considerable de servicios proporcionados a través de las redes llegó un momento que se observó que existían dos recursos limitados: el ancho de banda y la latencia. 

Había llegado el momento de gestionar eficientemente estos dos recursos si se quería seguir prestando servicios de calidad puesto que se hacía inviable su aumento infinito. 

Parte de la solución para esta administración eficiente de recursos fue la llegada de la calidad de servicio o, en sus siglas en inglés: QoS. 

El mecanismo de la QoS es tan simple como efectivo. Entendemos que no todos los tráficos generados en nuestro ordenador tienen un comportamiento y un nivel de criticidad equivalente. No es lo mismo que una página web nos tarde un segundo más en cargar que el hecho de que una conversación a través de Skype tenga ese mismo retraso de un segundo. Para solucionar este problema se decidió priorizar el tráfico en función de su sensibilidad ante determinados factores inherentes a una red de computadores: latencia, pérdidas de paquetes, límite de ancho de banda, etc. 

Esta priorización se puede llevar a cabo en muchos niveles del modelo OSI pero la que aquí nos ocupa se realiza en el nivel 3, es decir, en los routers. 

¿Por qué? 

Fundamentalmente porque son elementos presentes en toda la cadena de comunicación desde el emisor de la información al receptor. Y aquí aparece la característica más importante a la hora de aplicar calidad de servicio a nuestro tráfico: todos y cada uno de los dispositivos que formen parte de la comunicación deben implementar QoS. En el momento en el que uno solo de estos dispositivos no tenga configurados los parámetros adecuados la QoS dejará de tener efecto. 

Esto es obvio si pensamos en que si nuestro objetivo es darle prioridad máxima a un tipo de tráfico, todos los dispositivos encargados de encaminar ese tráfico deben estar al tanto de esta situación. Si uno de ellos no lo hace, se producirá un retraso no previsto, una pérdida no deseada y, por tanto, una merma de la calidad del servicio. 

¿Cómo se prioriza?

La forma que tiene la QoS de ponerse a funcionar es tan simple como añadir una cabecera a los paquetes IP en la que se indique su nivel de QoS definido. La complejidad, esto es, el análisis y toma de decisiones, lo realizarán los routers dependiendo del tipo de QoS definida en ellos. La forma de decidir qué tráfico se marca con determinadas etiquetas se debe configurar y puede atender a variables de nivel 3: redes o subredes, vaiables de nivel 4: puertos/protocolos, interfaces específicas, etc. 

En la actualidad la QoS está muy presente en las empresas dado que debido a la convergencia de servicios, tráficos de voz, vídeo y datos suelen compartir medios de comunicación y es vital separar y dotar de la prioridad adecuada a cada uno de estos servicios.

Existe un interesante artículo que explica el tipo de marcado que se realiza a los paquetes IP en el siguiente enlace: http://diecarvi.wordpress.com/2013/05/05/understanding-qos-numbering/