Posts in "Sin categoría"

Mi repaso a este 2016 y mis planes para el 2017

Se agotan las últimas horas de este año y, como viene siendo costumbre, es momento de hacer balance de lo que ha sido este 2016 en líneas generales.

Este año tengo la sensación de que ha pasado volando y que, en poco más de un suspiro, me vuelvo a encontrar frente a la lista de propósitos de año nuevo. Pero, en realidad, como todos los años, 2016 ha sido un año plagado de miles de momentos: algunos buenos, otros quizá no tanto y otros maravillosamente geniales. Al final, la vida se trata de esto: caminamos por un sendero desconocido, en un atardecer sin fin, acompañados por distintas personas. Y a cada paso que damos, nuestros acompañantes, nuestras circunstancias, las piedras en el camino, las sorpresas inesperadas, todo, conforma el resultado de lo que somos hoy. ¿Quién sabe que nuevas aventuras nos traerá el año que comienza? Ahí, creo yo, que radica la verdadera belleza de la vida: lo que está por venir es una película nueva por estrenar.

Y aún así, lo importante se reduce siempre a lo mismo: parar por un instante, mirar a nuestro alrededor, respirar profundamente y saborear los millones de sabores que la vida nos ofrece.

Mis libros

Durante este año me he quedado bastante lejos del objetivo de 30 libros que me había propuesto. Sin embargo, aquí van los 5 mejores libros que me he leído:

  1. El fin de la eternidad – Isaac Asimov
  2. Dune – Frank Herbert
  3. A sangre y fuego – Manuel Chaves Nogales
  4. El enigma de Fermat – Simon Singh
  5. Yo antes de ti – Jojo Moyes

Ganador indiscutible la obra, desconocida para mi, de Isaac Asimov. Fue un auténtico descubrimiento y pasé rápidamente de la sorpresa inicial a un verdadero disfrute al leer la novela. Os la recomendaría un millón de veces más.

Mis películas

También ha habido mucho cine que disfrutar durante este año que termina. En cuanto a cine mis películas favoritas de 2016:

  1. Arrival
  2. La habitación
  3. Star Wars: Rogue One
  4. La gran apuesta
  5. Antes de ti

La llegada (Arrival) ha sido, sin ningún género de dudas, la película de este año. La suma casi perfecta de ciencia ficción, psicología e intriga con un final revienta-cerebros la elevan al número uno de mis favoritas este 2016.

Mis canciones

Aquí voy a hacer un poco de trampa. Ya que mi querido estomagante me lo está pidiendo, aquí van las 5 canciones que más he escuchado este 2016 en Spotify

  1. Esperança – Txarango
  2. Nothihg Left – Kygo
  3. Duele el corazón – Enrique Iglesias feat. Wisin
  4. Music de carrer – Txarango
  5. Roma – Bangkok – Baby K

Creo que muestra casi a la perfección (tal vez cambiaría la 5) lo que este año me ha acompañado como banda sonora. Esperança fue un descubrimiento que, hoy todavía, me arranca una sonrisa al escucharla. «Som un riu que sempre avança».

Lo que espero de 2017

Cuando nos encontramos ante una página en blanco que escribir, muchas veces nos vemos ante dos sensaciones fuertemente enfrentadas: por un lado, un arranque casi visceral que nos empuja a ponernos a escribir sin ni siquiera pensar. Por otro, una amalgama de dudas, que nacen de nuestro interior más profundo, que nos frenan y nos hacen vacilar.

La clave está, como en casi todas las cosas de la vida, en encontrar el punto medio: en pararse durante un instante a reflexionar, pero tampoco demasiado. Que la vida son dos días y más vale usar el corrector que dejar la página sin escribir.

Así, a este 2017 le pido un poco más de lo mismo: que me traiga momentos felices, que los riegue con las sonrisas de la gente que quiero y que me quiere y que las lágrimas que derrame y la tristeza que las acompañe, sean amortiguadas por los abrazos de las personas especiales que han decidido acompañarme. En definitiva, que la vida siga siendo vida y la vivamos y la sintamos nuestra.

Mis propósitos para 2017

Y, para terminar, aquí mi lista de 5 propósitos para este 2017 que empieza:

  1. Ser constante en mis objetivos. Sacar tiempo y dedicación cada día para ir alcanzando todas y cada una de las metas que me he propuesto. Parecerá que no es un objetivo definido, pero créedme, hoy más que nunca tengo claro que este es el más importante de todos.
  2. Leer, escribir, viajar, jugar y reirme. Disfrutar de mi tiempo libre.
  3. Por enésima vez, que el piano sea una fuente de desconexión.
  4. Meditar.
  5. Disfrutar mucho de todas las cosas que estoy haciendo y ponerlas en valor cada vez que consiga dar un paso ahcia adelante.

Por un 2017 plagado de momentos geniales y de sonrisas eternas.

https://www.youtube.com/watch?v=s43sptuwkvA

Volver a empezar

Quiero volver a escribir.

Es un hecho que llevo demasiado tiempo dándole vueltas a cómo enfocar el blog, qué es lo que al resto del mundo puede interesarle.

Me he pasado demasiado tiempo analizando, planificando y reflexionando acerca de eso sin entender que lo básico, lo fundamental, lo que convierte a un blog en una herramienta de comunicación maravillosa es que sencillamente me tengo que decidir a escribir lo que a mi me apetezca.

Y eso es lo que voy a intentar hacer a partir de ahora.

Sin presiones, sin complicaciones, sin grandiosos temas que tratar obligatoriamente.

Sencillamente dando rienda suelta a aquellos temas que me importan, que me parezcan curiosos, interesantes o ni siquiera eso.

Volvamos a empezar.

Crítica: Don Jon

Mi relación con Joseph Gordon-Levitt (Filmaffinity) ha sido particular y bastante cambiante con los años.

He de reconocer que no lo soportaba en Cosas de Marcianos (Serie de TV) (1996), tal vez influya el hecho de que para mi esa serie siempre ha sido bastante pobre en líneas generales. No obstante, él era de los que peor me caían.

Luego llegaría 10 razones para odiarte (1999) que sólo serviría para confundirme: no era una mala película pero tampoco me terminaba.

Pero empezó a cambiar la cosa. (500) Días juntos (2009), diez años después, fue el punto de inflexión. Empezaba a gustarme su forma de trabajar. Daba la talla. Convencía. Con esos ojos que muchas veces te hacían dudar de qué tabaco fumaba. Pero convencía.

img_donjon1

Y ya entonces llegaron Origen (2010), Looper (2012), Lincoln (2012) y El caballero oscuro: La leyenda renace (2012). Respeto ganado. El Robin que no era Robin pero que sabías que lo era había llegado a la Tierra Prometida de los buenos actores.

Así que con esas que estábamos hasta que imagino que se dijo: estoy explotando como actor, voy a hacerlo más difícil. Actor, director y guionista. Con un par.

Don Jon (2013)

Para empezar digamos que Don Jon es una buena película. No una muy buena película, no una película mediocre ni tampoco un bodrio infumable. Una película entretenida. Su argumento seduce al espectador, sobretodo al masculino, desde casi su comienzo porque fundamentalmente toda la película gira entorno a un único tema: la masturbación y el porno. 

Pero no os asustéis que está muy lejos de ser soez o de convertirse en un esperpento como lo fuera ¿Hacemos una porno? (2008).

img_donjon0

Trata, y en muchos momentos lo consigue, de ser fiel a una realidad incómoda: los hombres consumimos pornografía en la red. El que diga lo contrario miente. Y sobre esa base nos presenta a Don Jon, el arquetipo de triunfador frustrado. Que parece tenerlo todo: buen cuerpo, las chicas que quiere, un buen coche, etc., pero que se la machaca 5 o 6 veces al día porque el sexo real no le satisface.

Su vida habría seguido igual de no haber conocido a Barbara, una mujer «diez» según su escala. Ojo que hablamos de Scarlett Johanson. Entonces cae en sus redes, es imposible no hacerlo. Y es ahí cuando las cosas se precipitan y terminará por encontrarse frente a frente con sus miedos.

Trasfondo

No terminé la película sintiendo que buscase dar una lección contra el consumo excesivo de porno o contra la masturbación masculina sino más bien poner de relieve que en una sociedad de consumo como la que vivimos hemos relegado al sexo a un bien de consumo más. Y resulta un ejercicio interesante reflexionar sobre ello.

La Psicología ha dejado bastante claro que mientras no termine convirtiéndose en una adicción, el amarse a uno mismo, por mucho que algunos se empeñen en satanizarlo, no sólo no te deja ciego sino que produce una serie de beneficios. El problema no radica en proporcionarse placer uno mismo sino en que, en el proceso, terminemos despojando al acto físico de su contenido emocional. Que lleguemos a olvidar que al sexo se le debería llamar siempre hacer el amor cuando son dos personas las que lo practican.

img_donjon2

No es un bien de consumo más. Y no deberíamos permitir que se convierta en eso jamás.

Nota: 7/10

Redes: El comando network

Si precisamente hace unos días durante la realización del videotutorial #101 – OSPF y BGP – Redistribución | Capítulo 1 os comentaba la pequeña característica especial que tiene el comando «network» a la hora de emplearlo cuando configuramos IGPs (Interior Gateway Protocol) como OSPF o EIGRP, he encontrado esta estupenda entrada en el blog «Mis Libros de Networking» donde explican a la perfección su uso y sus características especiales.

Más allá de las configuraciones en sí mismas que podréis revisar accediendo al enlace, me parece realmente interesante mencionar el siguiente párrafo:

El comando network es el que se utiliza para definir en todos los casos qué interfaces del dispositivo participan del proceso de enrutamiento. Los efectos prácticos del comando son 3

1. Identifica las interfaces a través de las cuáles se publica información del protocolo de enrutamiento hacia los dispositivos vecinos.

2. Identifica las interfaces a través de las cuáles se recibe información del protocolo de enrutamiento publicada por los dispositivos vecinos.

3. La red o subred a la que está asociada la interfaz va a ser incluida en el proceso del protocolo de enrutamiento.

Queda bastante clara la explicación y lo que no es el comando network: no publica las redes que define sino que activa las interfaces que la dupla red / máscara incluye y son las redes asociadas a esas interfaces las que se terminarán publicando.

Os recomiendo que le echéis un vistazo al artículo al completo porque no tiene desperdicio.

# El comando Network en Mis Libros de Networking

Reseña: La ladrona de libros – Markus Zusak

[su_box title=»Aviso» style=»bubbles» box_color=»#a2e153″ title_color=»#50733d»]Esta entrada contiene spoilers (revelaciones de parte de la trama del libro) así que te recomiendo que si no has leído todavía el libro te abstengas de continuar. [/su_box]

La primera vez que oí hablar de «La Ladrona de Libros» fue a raíz de su inminente adaptación cinematográfica. Cuando adaptan un libro a la gran pantalla suele haber siempre detrás un motivo en particular: el libro se ha vendido mucho.

Es una cuestión de márketing simple: sabes que la gran mayoría de esos lectores van a ser un público asegurado en las salas de cine.

Esto, sin embargo, no es ni mucho menos un indicador de que el libro sea bueno. Ni siquiera decente. Tenemos adaptaciones de libros mediocres: «Ángeles y Demonios» o «Eragon» son las primeras que me vienen a la cabeza.

Con La Ladrona de Libros recibí algunas referencias positivas de la película y del libro así que decidí ponerme manos a la obra con este último.

La novela es, para empezar, un cuento maravilloso. Puede que a algunos les parezca triste por lo cruel de su final, pero es lo que al cine fue en su día La Vida es Bella. Una historia perfectamente narrada. Donde las historias conviven con la crudeza de la guerra, de esa gran guerra que no sólo asoló Europa sino que sacó a relucir las grandes miserias de la condición humana.

Y en esto, Markus Zusak, su autor, se muestra como todo un experto.

Narrada desde la visión de la «Muerte», La Ladrona de Libros nos cuenta la vida de una pequeña niña que ya desde bien temprano ha de enfrentarse a grandes obstáculos y dificultades para poder sobrevivir.

Desde el mismo instante en que conoces a Liesel Meminger te enamoras perdidamente de ella. De su inocencia. De su visión transparente de la vida. Su única arma contra un mundo inexplicablemente cruel e irracional son las palabras y su imaginación. Y gracias a ellas sobrevive.

Liesel es una alemana con unos padres incómodos para un régimen nazi incipiente. Ese es el primer obstáculo que debe sortear y para ello termina en casa de los Hubermann (Hans y Rosa): alemanes de los de verdad, los arios de raza pura que tanto gustaron a la antítesis aria que fuera Adolf Hitler. Pura contradicción.  Bondad y desprecio. Blanco y negro. Eso es la humanidad.

Lo interesante del libro es precisamente lo humano que resulta. Por encima de la locura que llevó al exterminio de millones de judíos, a la muerte de millones soldados en una guerra sin sentido (¿alguna lo ha tenido?), a la posterior represalia a millones de alemanes, muy por encima, sutilmente, mezclándose y apareciendo entre las grietas de la dignidad humana, surgen las personas.

El vecino rubio y ario que se pintó de negro para parecerse a Jesse Owens. ¡Ay Rudy! Para mi ese el PERSONAJE de la novela. En cualquier momento te grita un Heil! Hitler! sin tener la menor de las ideas de lo que en realidad supone gritarlo. Cargado de amor por los que le rodean.  Él es el alemán medio. Él es el ser humano medio.  El que dejó que las cosas sucedieran. ¿Culpable? Sí, es posible. Pero al fin y al cabo también lo somos nosotros permitiendo las tropelías que suceden en nuestro país.

Luego tenemos a los padres adoptivos. El más que adorable Hans y la tierna (aunque severa) Rosa. Son tan entrañables que cuando el escritor decide arrancártelos sin avisar tienes la obligación de odiarlo infinitamente. Son el padre y la madre. El ying y el yang de una familia. Equilibrio a pesar de todo. Y de nuevo son alemanes medios. Alemanes que no alcanzan a entender por qué es obligatorio odiar a alguien por ser moreno, por tener los ojos castaños o unas creencias diferentes.

Y por último está Max. La imagen viva del oprobio, de la sin razón humana, de lo más animal de nuestra condición. Max es judío. Y se acabó. Eso es todo. ¿Buena o mala persona? ¿Inteligente o estúpido?. Eso da exactamente igual. Nació judío y con ello todo lo demás dejó de importar. Porque una sociedad entera, un régimen al completo, creyó ciegamente a un enajenado y sus teorías raciales y lo consideró menos que humano: lo consideró prescindible.

Lo genial es que Max además de judío es un tipo estupendo. Bordea la muerte en tantas ocasiones que asumes que al final también caerá al hoyo. Intentas no acercarte demasiado, sabes que es frágil, intuyes que no durará (es un judío en medio de la Alemania nazi, por favor) pero al final resulta que termina siendo uno de los ejes de la narración.

El libro te atrapa por su narrativa heterodoxa, por sus formas extrañas, por sus giros hacia adelante y hacia atrás. Te seduce. Capaz de destriparte el final y aún así dejarte con la boca abierta con él.

Se ha convertido sin lugar a dudas en uno de mis grandes libros de 2014.

Nota: 9/10

Propósitos para 2014

Casi sin tiempo no podía dejar pasar el 2013 sin preparar una lista, esta vez más acorde a la realidad, de lo que espero en este 2014.

Cuando llega final de año muchos tenemos la tendencia a hacer un resumen y pensar en aquello con lo que nos quedamos y aquello que nos gustaría cambiar.

Mi 2014 va a tener tres grandes objetivos.

1. Decisión. Mi talón de Aquiles eterno. Mi incapacidad para tomar decisiones muchas veces ha significado tomar la más incorrecta de todas las posibles: ninguna. Quiero y pienso esforzarme mucho por ser capaz de tomar las decisiones adecuadas evaluando todo aquello que en el momento de tomarlas tenga a mi alcance. Aceptar esas decisiones como las correctas en ese momento y no mirar más hacia atrás.

2. Reflexión. Una de las grandes cosas que siempre ha estado en mi lista de propósitos y que jamás me he aventurado a darle forma ha sido la de la meditación. He tenido tímidos intentos pero nunca me lo he tomado en serio. Este 2014 va a ser el año de meditar, comprender, aprender y aceptar.

3. Cuerpo. Este último año he dado un salto cuantitativo en cuanto a lo que se refiere al deporte en mi vida diaria. Ahora falta completarlo. Manteniendo y mejorando mi día a día y, además, complementándolo con una alimentación más sana y adecuada.

Nada más que tres. Luego ya detrás están los de siempre: dejarme tiempo para disfrutar de mis pequeños placeres, conseguir un título de inglés, seguir mejorando mis conocimientos, seguir mejorando como persona y como profesional, etc.

Por cierto, intentaré ser razonable este año y marcarme como objetivo los 36 libros. 

 

LAB: Configuración Básica de OSPF

Dado el siguiente escenario:

LAB_1

Tenemos dos routers asociados a dos redes LAN independientes que no tienen conectividad entre sí. El objetivo de este laboratorio será definir un área OSPF común en el que los routers intercambien las rutas a su redes internas a través de la misma.

Para ello configuramos en primer lugar el router de Valencia:

Empezaremos definiendo las interfaces. Al tratarse de un router de la serie 1700 sólo disponemos de una interfaz FastEthernet que será la que emplearemos para conectarnos con el router del ISP. Para emular la subred de Valencia asignaremos la IP del rango 10.1.0.0/16 a una interfaz Loopback que hará las funciones de equipo dentro de la subred.

interface FastEthernet0
 description ENLACE CON MADRID
 ip address 10.0.0.1 255.255.255.252

interface Loopback0
 ip address 10.1.0.1 255.255.0.0
!

Realizaremos el mismo proceso en el router de Madrid:

interface FastEthernet0
 description ENLACE CON VALENCIA
 ip address 10.0.0.5 255.255.255.252

interface Loopback0
 ip address 10.1.0.1 255.255.0.0

Y por último el router del ISP dispondrá de dos enlaces FastEthernet dedicados a cada sede:

interface FastEthernet0/0
 description ISP TO VALENCIA
 ip address 10.0.0.2 255.255.255.252
!
interface FastEthernet1/0
 description ISP TO MADRID
 ip address 10.0.0.6 255.255.255.252
!

Una vez configurados los equipos podemos comprobar que desde la LAN de Valencia no se alcanza la LAN de Madrid.

VALENCIA#ping 10.2.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Si observamos la tabla de enrutamiento veremos cómo, como es obvio, el router de Valencia sólo puede alcanzar las redes a las que está conectado.

VALENCIA#sh ip route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/30 is directly connected, FastEthernet0
C       10.1.0.0/16 is directly connected, Loopback0

Para solucionar esta situación haremos uso de un protocolo de enrutamiento dinámico: OSPF.

Debemos definir un Área OSPF en la que los tres dispositivos intercambien rutas. Como el Router ISP no tiene rutas propias que intercambiar nos servirá exclusivamente de pasarela entre Valencia y Madrid.

Configuraremos de forma análoga OSPF tanto en Valencia como en Madrid.

VALENCIA
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.3 area 0
 network 10.1.0.0 0.0.255.255 area 0

MADRID
router ospf 1
 log-adjacency-changes
 network 10.0.0.4 0.0.0.3 area 0
 network 10.2.0.0 0.0.255.255 area 0

Por último configuraremos OSPF en el ISP y observaremos como se producen las adyacencias oportunas.

router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.3 area 0
 network 10.0.0.4 0.0.0.3 area 0

Una vez el proceso converge, las rutas de todos los dispositivos han sido compartidas y nos encontramos con que las tablas de enrutamiento de los 3 routers han sufrido una actualización gracias al proceso OSPF. Esto nos va a permitir tener interconectividad entre las redes LAN de Madrid y Valencia.

VALENCIA#ping 10.2.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/52/96 ms

ISP#sh ip route
Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.0.0.8/30 is directly connected, FastEthernet2/0
O       10.2.0.1/32 [110/2] via 10.0.0.5, 00:07:28, FastEthernet1/0
O       10.1.0.1/32 [110/2] via 10.0.0.1, 00:07:28, FastEthernet0/0
C       10.0.0.0/30 is directly connected, FastEthernet0/0
C       10.0.0.4/30 is directly connected, FastEthernet1/0

Podéis descargaros la topología para GNS3  con la configuración aplicada desde el siguiente enlace:

http://www.sergiomadrigal.com/labs/OSPF1.zip

¿Por qué Parship?

Resulta interesante cómo las plataformas de encuentros online han ido multiplicándose conforme las redes han tenido mayor penetración en los hogares españoles.

Se entiende que, por tanto, son una respuesta real y rentable para que las personas logren el objetivo de encontrar compañero/a o al menos aumentar sus relaciones sociales.

En medio de todo esto ha nacido una nueva plataforma de contactos, PARSHIP, que pretende mejorar las prestaciones de sus potenciales competidores (meetic o Badoo) añadiendo características que puedan mejorar la experiencia del usuario

Sin lugar a dudas, lo más interesante de este tipo de plataformas y en especial de PARSHIP son los cálculos que realizan basándose en tu perfil para definir la compatibilidad que tienes con otros usuarios/as y así acotar tus «aspirantes» a aquellos/as con los que tengas más probabilidades de congeniar.

Me encantaría saber qué tipo de algoritmo emplean.

En definitiva, a lo que iba, es que si necesitas pareja o sencillamente quieres conocer a gente cerca de tí, pásate por PARSHIP y lo pruebas.

Ilusión y proyectos

Siempre he sido de aquellos que piensan que en esta vida sólo queriendo cada día un poquito más, no conformándote con aquello que la vida te va dejando, es la única forma de poder vencer en la carrera con un final definido que comenzamos todos al nacer.

Estos últimos días he tenido una pequeña mezcla de sensaciones debidas probablemente a dos situaciones muy puntuales, una de carácter personal que parece estar resolviéndose y la otra de carácter profesional con la publicación de lo que son los primeros pasos de Wala! la iniciativa empresarial que he comenzado junto con dos compañeros de profesión.

En ambos casos, el cariz que está tomando la situación hace que me esté ilusionando verdaderamente con los proyectos a corto y medio plazo que este 2011 ha traído bajo el brazo.

Ilusión. Motor de  cualquier cosa, cualquier relación, cualquier objetivo en la vida. Con ella generamos la motivación suficiente para creernos capaces de llegar a cualquier sitio, escalar cualquier montaña, alcanzar límites y superarlos.

Y en esas estamos, iniciando con muchas fuerzas y con muchas ganas un proyecto en el que tenemos depositadas las ilusiones. Porque es el momento, en medio de toda esta galopante crisis que parece habernos dejado a todos sin esa capacidad de creer en nuestra posibilidades, de ver esa luz que nos indica que el camino es posible y que llega el final del túnel.